Emails Notifications Blocked
Incident Report for Mace Innovations
Resolved
This incident has been resolved.
Posted Dec 22, 2020 - 12:37 MST
Identified
We identified an issue where one of the IP addresses we use for sending email notifications is being blocked by a variety of spam filters. We are swapping IP addresses within our pool of addresses to phase out the impacted IP address.
Posted Dec 22, 2020 - 12:06 MST
This incident affected: Services (Email Notifications).