Experian Velocify Lead Import - Service(s) Failed to Import Lead(s)
Incident Report for Mace Innovations
Resolved
We identified and resolved the issue.
Posted Apr 26, 2019 - 19:00 MDT
Identified
We identified one or more failures within our import service. We are investigating the issue current. Stay tuned for more updates as we investigate.
Posted Apr 26, 2019 - 18:25 MDT
This incident affected: Experian (Velocify Import Service).