Blend Auto Loan Push - Delayed Loan Imports
Incident Report for Mace Innovations
Postmortem

Overview

On Sunday, November 3rd at approximately 1:30pm MST our Auto Loan Push Blend Integration feature started processing slower than normal. Features impacted were:

  • Auto-push-loans

After investigating the issue we identified we received a 500 (“Internal Server Error”) from Blend while trying to retrieve the Fannie 3.2 files (/home-lending/applications/{id}/file-export). We resumed importing loans around 4:30pm MST. We are working closely with Blend to determine why these errors are occurring and a way to prevent them moving forward. We updated application code on our side to handle it gracefully as a short term fix.

Changes Implemented

  • Application Code Modifications

    • SMS alerts sent when we receive a 500 (“Internal Server Error”) from the Blend API.
    • Added code to trap and handle 500 errors gracefully so it doesn’t impact new auto loan import push events.

Closing

We appreciate your business and are committed to continuing to improve the performance and stability of the Encompass / Blend Integration. If you have any questions or would like further details, please email [email protected].

Posted Nov 06, 2019 - 12:14 MST

Resolved
Auto push loan imports were not imported near-realtime.
Posted Nov 03, 2019 - 13:30 MST