Degraded Performance
Incident Report for Mace Innovations
Resolved
We resolved the issue. We monitored systems for 2-3 hours to ensure performance was restored.
Posted Nov 25, 2019 - 17:58 MST
Investigating
We are currently investigating slower than expected speeds with one of our cloud providers. Systems are functioning but not at the rate that we like to see.
Posted Nov 25, 2019 - 11:11 MST
This incident affected: Blend (Integration) and Services (Event Notifications, Email Notifications).